Bienvenue, Invité
Merci de vous identifier ou de vous inscrire.    Mot de passe perdu?

aucune page n'éxiste - liens morts
(1 lecteur(s)) (1) Invité(s)
Aller en basPage: 1234
SUJET:

aucune page n'éxiste - liens morts

#7745
liloulila13
Expert Boarder
Messages: 123
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:aucune page n'éxiste - liens morts

Il y a 9 Années
Karma: 0  
Apparemment ca ne vient pas de la, le problème est toujours présent, même après plusieurs installations...
 
L'administrateur a désactivé l'accès public en écriture.
#7752
Gabriiiel
I love Magento.
Expert Magento
Messages: 4118
graph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
Sexe: Masculin gabriel.bouhatous Formation Magento Audit Conseil gabriel.bouhatous Ask me :) Lieu: Paris

Re:aucune page n'éxiste - liens morts

Il y a 9 Années
Karma: 112  
Y'a-t-il un nom de domaine associé à ton installation ?

Je veux dire, y accèdes-tu via une adresse du genre monhébergeur.com/~monespace

Ou via www.monespace.com ?
 
Expert Magento @ The e-Commerce Academy

L'administrateur a désactivé l'accès public en écriture.
#7769
liloulila13
Expert Boarder
Messages: 123
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:aucune page n'éxiste - liens morts

Il y a 9 Années
Karma: 0  
Non il n'y a pas de nom de domaine pour y accéder. L'adresse est composée de numéro :
213..../~mapartie/index.php/admin
 
L'administrateur a désactivé l'accès public en écriture.
#7772
Gabriiiel
I love Magento.
Expert Magento
Messages: 4118
graph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
Sexe: Masculin gabriel.bouhatous Formation Magento Audit Conseil gabriel.bouhatous Ask me :) Lieu: Paris

Re:aucune page n'éxiste - liens morts

Il y a 9 Années
Karma: 112  
Si tu associes un domaine à 213..../~mapartie tu verras que tu obtiendras ce que tu souhaites c'est à dire disparition de index.php dans l'url.

Maintenant, le pourquoi du comment, je ne peux pas te dire.
 
Expert Magento @ The e-Commerce Academy

L'administrateur a désactivé l'accès public en écriture.
#7806
liloulila13
Expert Boarder
Messages: 123
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:aucune page n'éxiste - liens morts

Il y a 9 Années
Karma: 0  
je pense que je vais faire ca.

Merci Gabriiiel
 
L'administrateur a désactivé l'accès public en écriture.
#7807
Gabriiiel
I love Magento.
Expert Magento
Messages: 4118
graph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
Sexe: Masculin gabriel.bouhatous Formation Magento Audit Conseil gabriel.bouhatous Ask me :) Lieu: Paris

Re:aucune page n'éxiste - liens morts

Il y a 9 Années
Karma: 112  
Ce serait pas mal si quelqu'un avait un retour sur la situation, comment est-ce techniquement parlant possible notamment ?
 
Expert Magento @ The e-Commerce Academy

L'administrateur a désactivé l'accès public en écriture.
#7842
Fibo
Platinum Boarder
Messages: 369
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
Conseil & coaching informatiques Lieu: Marseille

Re:aucune page n'éxiste - liens morts

Il y a 9 Années
Karma: 3  
C'est forcément un pb d'url rewrite... les différents points à vérifier, et qui doivent être "harmonisés" sont:
- le rewrite htacess marche-t-il convenablement?
- passe-t-il à Magento une info que celui-ci interprète correctement?
-- sur la plupart des installs magento, si l'on ne précise pas dans la config une url admin specifique, on aboutit au même endroit avec /index.php/admin/ et /admin/
-- pas tout à fait vrai, car le rewrite n'a lieu que s'il n'y a pas de ficheir ou de répertoire de ce nom (si on crée un répertoire /admin... on valler dans ce répertoire me semble-t-il)
- tu peux nous recopier ta ligne rewritebase?

>> Ton hébergement est-il bien configuré pour exécuter /toto/index.php
quand on lui indique /toto/?
 
Dernière édition: 18/01/09 à  08:44 Par Fibo.
L'administrateur a désactivé l'accès public en écriture.
#7870
liloulila13
Expert Boarder
Messages: 123
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:aucune page n'éxiste - liens morts

Il y a 9 Années
Karma: 0  
Voici mon htaccess :

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 128M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems...
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don't compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don't deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## developer.yahoo.com/performance/rules.html#expires

ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## developer.yahoo.com/performance/rules.html#etags

#FileETag none

Ma configuration dans Magento:
("utiliser la réécriture : non" c'est pour que mes liens soient justes sur mes pages, mais j'avais yes avant)

EDIT Gabriiiel
 
Dernière édition: 19/01/09 à  04:59 Par Gabriiiel.
L'administrateur a désactivé l'accès public en écriture.
Revenir en hautPage: 1234
Modérateur: admin, Gabriiiel, ILOA, zuiko