Bienvenue, Invité
Merci de vous identifier ou de vous inscrire.    Mot de passe perdu?

Installation du module ogone
(1 lecteur(s)) (1) Invité(s)
Aller en basPage: 1...3456789...25
SUJET:

Installation du module ogone

*
#14570
Heriquet
Gold Boarder
Messages: 274
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Installation du module ogone

Il y a 8 Années, 7 Mois
Karma: 1  
Effectivement je l'avais oublié mais même avec ca fait la même erreur... et y a donc pas de retour sur mon site, le panier n'est pas vidé.
 
L'administrateur a désactivé l'accès public en écriture.
#14580
nnoel
Junior Boarder
Messages: 21
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Installation du module ogone

Il y a 8 Années, 7 Mois
Karma: 0  
c'est curieux, dans mes tests cela semble fonctionner.
Le petit souci est que le retour de chez ogone ne se fait pas dans la session de l'acheteur.
(A creuser du côté de la config du compte test du côté ogone?)
L'affichage du contenu du panier persiste jusqu'au moment où la commande est complète. Peut-être un effet de cache?

*** correction ***
si je déclare l'url du site et l'url du catalogue (2 x http: //monsite.com/magento/) dans la config du côté magento, le retour se fait bien dans la session de l'acheteur et un refresh ou un logout/login vide bien le panier.
 
Dernière édition: 05/06/09 à  04:31 Par nnoel.
L'administrateur a désactivé l'accès public en écriture.
#14588
Heriquet
Gold Boarder
Messages: 274
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Installation du module ogone

Il y a 8 Années, 7 Mois
Karma: 1  
Aucune idée...

Mais c'est embêtant en tout cas...

J'aimerais trouver des gens qui ont réussi à faire marcher le module complètement... ou en tout cas le développeur mais j'ai pas de réponse quand je tente de le contacter...
 
L'administrateur a désactivé l'accès public en écriture.
#14590
nnoel
Junior Boarder
Messages: 21
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Installation du module ogone

Il y a 8 Années, 7 Mois
Karma: 0  
si je déclare l'url du site et l'url du catalogue (2 x http: //monsite.com/magento/) dans la config du côté magento, le retour se fait bien dans la session de l'acheteur et un refresh ou un logout/login vide bien le panier.
 
L'administrateur a désactivé l'accès public en écriture.
#14594
mangu
Senior Boarder
Messages: 40
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
Sexe: Masculin the_only_real_kinglizard stephzan@live.be Lieu: Ath Date anniversaire: 18/09

Re:Installation du module ogone

Il y a 8 Années, 7 Mois
Karma: 1  
nnoel écrit:
bonjour à tous,

'back in town'

pour faire fonctionner le module ogone (gratuit)


  1. installer le module 'à la main' comme expliqué à la première page

  2. créer un compte test chez ogone

  3. configurer le compte test chez ogone (RTFM) avec au moins

    • l'adresse de votre site

    • l' acceptation de paiements en euros

    • l'activation d'au moins un module de paiement (je vous conseille de débuter avec uniquement la carte Visa)


  4. configurer le module dans magento

    • mode test: oui

    • activé: oui

    • mettre un Titre

    • votre identifiant (login) du compte test

    • sélectionner l'Euro

    • Français

    • donner un titre à la page (par ex: test ogone)

    • dans la liste déroulante du bas, activer (au moins) la méthode de paiement Visa

    • sélectionner le statut nouvelle commande

    • il ne faut rien configurer de plus





vous pouvez à présent effectuer un test de paiement avec une carte de crédit visa
le numéro de la carte visa test est 4111 1111 1111 1111 (RTFM)

bon tests à tous


J'ai bien installé le module dans magento, il apparait dans system/configuration/avancée mais pas dans magento_connect (normal je pense vu qu'il n'a pas été installé via magento connect), j'ai créé et configuré un compte test chez ogone.

Par contre, je ne vois pas où se trouvent les otpions (mode test, etc...) où sont-elles?

Si je vais dans system/configuration/mode de paiement, voici ce que j'ai:
Code :

Carte de paiement enregistrée
Règlement d'un sous-total nul
Authorize.net
Payflow Pro
PayPal Express Checkout
PayPal Website Payments Pro - Paiements directs
PayPal Website Payments Standard
PayPal Website Payments Pro (Payflow Edition) - Express Checkout
PayPal Website Payments Pro (Payflow Edition) - Direct Payments



Visiblement pas de ogone

Que faire?
 
Apprendre est toujours long, mais comprendre est si bon.
L'administrateur a désactivé l'accès public en écriture.
#14595
Heriquet
Gold Boarder
Messages: 274
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Installation du module ogone

Il y a 8 Années, 7 Mois
Karma: 1  
nnoel écrit:
si je déclare l'url du site et l'url du catalogue (2 x http: //monsite.com/magento/) dans la config du côté magento, le retour se fait bien dans la session de l'acheteur et un refresh ou un logout/login vide bien le panier.

Ah bin j'ai fait une connerie que je vais partager car d'autres tomberont surement dessus !

Pour url du site et du catalogue, j'ai mis 2x "www.monsite.be/"... il faut bien respecter le format suivant : "www.monsite.be/". Après je suis redirigé sur ma homepage.

Dernier souci... le panier est toujours remplis... hors je pensais qu'il se viderait !

Autre chose, dans mes commandes, quand je regarde ma commande en mode admin, je vois ceci :

5 juin 2009 13:34:38|En cours de traitement
Client Non notifié
Customer was redirected to OgonePayment


Je n'ai pas d'indice qui me dit que ma commande a été payée...
 
Dernière édition: 05/06/09 à  06:21 Par Heriquet.
L'administrateur a désactivé l'accès public en écriture.
#14597
Heriquet
Gold Boarder
Messages: 274
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Installation du module ogone

Il y a 8 Années, 7 Mois
Karma: 1  
J'ai peut-être trouvé la cause de mon problème..

nnoel, tu as mis quoi dans le compte test Ogone pour le champs "4. Retour de l'info au marchand après paiement"

Il y a 2 urls à remplir, moi j'ai mis "www.monsite.be/checkout/onepage/". Il devrait pas y avoir un lien du genre "...ogone/success" ?
 
L'administrateur a désactivé l'accès public en écriture.
#14614
nnoel
Junior Boarder
Messages: 21
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Installation du module ogone

Il y a 8 Années, 7 Mois
Karma: 0  
dans les urls de retour du côté magento (success/error/decline) je n'ai rien mis, uniquement les url site et catalogue (.....monsite.com/magento 2x)
 
L'administrateur a désactivé l'accès public en écriture.
Revenir en hautPage: 1...3456789...25
Modérateur: admin, Gabriiiel, ILOA, zuiko